Intermittent Connectivity Issues - Recurring
Incident Report for Sense
Postmortem

Some Sense Messaging users have been experiencing intermittent connectivity issues this week. We discovered a software bug that was triggered by a certain pattern of increased scale and usage. As a result, some customers were unable to send messages or had to reconnect.

We have identified the root cause of the bug and have taken several mitigating steps to reduce the impact of this issue. We are actively working on the updates to the infrastructure to resolve the bug and have instituted additional monitoring to ensure scaling without issues moving forward. We will continue to provide updates through email as well as here on our Sense status page.

On behalf of the entire Sense team, we apologize for any inconvenience this issue may have caused you and your team. Sense has prioritized work this quarter to ensure the stability of our key services to continue delivering a delightful and reliable product experience.

Posted Jul 27, 2022 - 14:09 PDT

Resolved
We have confirmed this connectivity issue has been resolved and we're seeing stable connection with all users. The send button will populate as expected when typing a message.

If you or your users are still experiencing this issue after refreshing, please submit a ticket through our support portal:
https://support.sensehq.co/hc/en-us/requests/new
Posted Jul 26, 2022 - 15:47 PDT
Monitoring
Our team has pushed a fix for the connectivity issues and we're seeing stable connection for all users and the send button populating as expected once more. Please have any affected user refresh their current page if still experiencing this error.

If you or your users are still experiencing this issue after refreshing, please submit a ticket through our support portal:
https://support.sensehq.co/hc/en-us/requests/new
Posted Jul 26, 2022 - 14:47 PDT
Identified
We have identified this connectivity issue and are working on a release to correct this issue. We will provide updates on this as we receive them
Posted Jul 26, 2022 - 13:07 PDT
Update
We are continuing to investigate this issue.
Posted Jul 26, 2022 - 12:39 PDT
Investigating
We have seen the connectivity issue has recurred and users are experiencing issues not being able hit the send option for SMS due to no connectivity.
Our team is investigating what caused this to recur and we will continue to provide updates as we receive them
Posted Jul 26, 2022 - 12:39 PDT
This incident affected: Sense Messaging (Messaging Chrome Extension, Messaging Web Portal, Messaging Mobile App, Messaging Analytics).